300 Beispiele

Grafif

Countif

Numerische Kriterien | Texttricks | Boolesche Werte zählen | Fehler zählen | Und Kriterien | Oder Kriterien | Mehr über Countif | Magie zählen



Die Mächtigen ZÄHLENWENN-Funktion in Excel zählt Zellen nach einem Kriterium. Diese Seite enthält viele leicht verständliche COUNTIF-Beispiele.

Numerische Kriterien

Verwenden Sie die ZÄHLENWENN-Funktion in Excel, um Zellen zu zählen, die einem Wert entsprechen, Zellen zu zählen, die größer oder gleich einem Wert sind usw.





1. Die untenstehende ZÄHLENWENN-Funktion zählt die Anzahl der Zellen, die gleich 20 sind.

Einfache ZÄHLENWENN-Funktion in Excel



2. Die folgende ZÄHLENWENN-Funktion liefert genau das gleiche Ergebnis.

Zählen Sie Zellen gleich dem Zellenwert

3. Die folgende Funktion ZÄHLENWENN zählt die Anzahl der Zellen, die größer oder gleich 10 sind.

Zellen zählen, die größer oder gleich dem Wert sind

4. Die folgende ZÄHLENWENN-Funktion liefert genau das gleiche Ergebnis.

ZÄHLENWENN-Funktion und der kaufmännische Und-Operator

Erläuterung: Der Operator & verbindet das Symbol 'größer oder gleich' und den Wert in Zelle C1.

5. Die folgende Funktion ZÄHLENWENN zählt die Anzahl der Zellen, die ungleich 7 sind.

Zellen zählen, die nicht dem Wert entsprechen

6. Die folgenden ZÄHLENWENN-Funktionen zählen die Anzahl der Zellen, die gleich 3 oder 7 sind.

Zwei ZÄHLENWENN-Funktionen in Excel

Texttricks

Verwenden Sie die ZÄHLENWENN-Funktion in Excel und einige Tricks, um Zellen zu zählen, die bestimmten Text enthalten. Schließen Sie Text immer in doppelte Anführungszeichen ein.

1. Die untenstehende ZÄHLENWENN-Funktion zählt die Anzahl der Zellen, die genau Stern enthalten.

ZÄHLENWENN-Funktion in Excel, genau

2. Die folgende ZÄHLENWENN-Funktion zählt die Anzahl der Zellen, die genau Stern + 1 Zeichen enthalten. Ein Fragezeichen (?) entspricht genau einem Zeichen.

ZÄHLENWENN-Funktion, Fragezeichen

3. Die folgende ZÄHLENWENN-Funktion zählt die Anzahl der Zellen, die genau Stern + eine Reihe von null oder mehr Zeichen enthalten. Ein Sternchen (*) entspricht einer Reihe von null oder mehr Zeichen.

Welche der folgenden Optionen können Sie anwenden, nachdem Sie ein Diagrammelement ausgewählt haben?

ZÄHLENWENN-Funktion, Sternchen

4. Die nachfolgende ZÄHLENWENN-Funktion zählt die Anzahl der Zellen, die in irgendeiner Weise ein Sternchen enthalten.

Alle Vorkommen zählen

5. Die folgende ZÄHLENWENN-Funktion zählt die Anzahl der Zellen, die Text enthalten.

Zellen zählen, die Text enthalten

Boolesche Werte zählen

Verwenden Sie die ZÄHLENWENN-Funktion in Excel, um boolesche Werte (TRUE oder FALSE) zu zählen.

1. Die untenstehende ZÄHLENWENN-Funktion zählt die Anzahl der Zellen, die das boolesche WAHR enthalten.

WAHR zählen

2. Die folgende ZÄHLENWENN-Funktion zählt die Anzahl der Zellen, die den Booleschen Wert FALSE enthalten.

FALSCH zählen

Fehler zählen

Verwenden Sie die ZÄHLENWENN-Funktion in Excel, um bestimmte Fehler zu zählen.

1. Die folgende ZÄHLENWENN-Funktion zählt die Anzahl der Zellen, die das #NAME? Error.

#Name zählen? Fehler

2. Die folgende Matrixformel zählt die Gesamtzahl der Fehler in einem Zellbereich.

Fehler zählen

Hinweis: Beenden Sie eine Array-Formel, indem Sie STRG + UMSCHALT + EINGABETASTE drücken. Excel fügt die geschweiften Klammern {} hinzu. Besuchen Sie unsere Seite über Zählfehler für detaillierte Anweisungen zum Erstellen dieser Arrayformel.

Und Kriterien

Das Zählen mit Und-Kriterien in Excel ist einfach. Die Funktion ZÄHLENWENN (mit dem Buchstaben S am Ende) in Excel zählt Zellen basierend auf zwei oder mehr Kriterien.

1. Um beispielsweise die Anzahl der Zeilen zu zählen, die Google und Stanford enthalten, verwenden Sie einfach die Funktion ZÄHLENWENN.

ZÄHLENWENN-Funktion in Excel

Oder Kriterien

Das Zählen mit Oder-Kriterien in Excel kann schwierig sein.

1. Die folgenden ZÄHLENWENN-Funktionen zählen die Anzahl der Zellen, die Google oder Facebook enthalten (eine Spalte). Bisher keine Raketenwissenschaft.

Einfach oder Kriterien

2. Wenn Sie jedoch die Anzahl der Zeilen zählen möchten, die Google oder Stanford enthalten (zwei Spalten), können Sie die ZÄHLENWENN-Funktion nicht einfach zweimal verwenden (siehe Bild unten).

Falsche Formel

Hinweis: Zeilen, die Google und Stanford enthalten, werden zweimal gezählt, sollten aber nur einmal gezählt werden. 4 ist die Antwort, nach der wir suchen.

3. Die folgende Array-Formel macht den Trick.

Zählen mit Oder-Kriterien in Excel

Hinweis: Beenden Sie eine Array-Formel, indem Sie STRG + UMSCHALT + EINGABETASTE drücken. Excel fügt die geschweiften Klammern {} hinzu. Besuchen Sie unsere Seite über Zählen mit oder Kriterien für detaillierte Anweisungen zum Erstellen dieser Arrayformel.

Mehr über Countif

Die ZÄHLENWENN-Funktion ist eine großartige Funktion. Schauen wir uns noch ein paar weitere coole Beispiele an.

1. Die untenstehende ZÄHLENWENN-Funktion verwendet a benannter Bereich . Der genannte Bereich Ages bezieht sich auf den Bereich A1:A6.

ZÄHLENWENN und benannter Bereich

2. Die nachfolgende ZÄHLENWENN-Funktion zählt die Anzahl der Zellen, die kleiner sind als der Altersdurchschnitt (32,2).

ZÄHLENWENN und MITTELWERT

3. Um Zellen zwischen zwei Zahlen zu zählen, verwenden Sie die Funktion ZÄHLENWENN (mit dem Buchstaben S am Ende).

Zellen zwischen zwei Zahlen zählen

4. Verwenden Sie die ZÄHLENWENN-Funktion, um zu zählen, wie oft jeder Wert im benannten Bereich Ages vorkommt.

Zählen Sie, wie oft jeder Wert auftritt

Hinweis: Zelle B2 enthält die Formel =ZÄHLENWENN(Alter,A2), Zelle B3 =ZÄHLENWENN(Alter,A3) usw.

5. Fügen Sie die hinzu WENN-Funktion um die Duplikate zu finden.

Verwenden Sie ZÄHLENWENN, um Duplikate zu finden

Tipp: Verwenden Sie ZÄHLENWENN und die bedingte Formatierung, um Duplikate finden und markieren im Excel-Format.

Magie zählen

Die ZÄHLENWENN-Funktion kann nicht zählen, wie oft ein bestimmtes Wort in einer Zelle oder einem Zellbereich vorkommt. Alles was wir brauchen ist ein bisschen Magie!

1. Die folgende Formel zählt, wie oft das Wort „Hund“ in Zelle A1 vorkommt.

Zählen Sie, wie oft ein bestimmtes Wort in einer Zelle vorkommt

2. Die folgende Formel zählt, wie oft das Wort „Hund“ im Bereich A1:A2 vorkommt.

Zählen Sie, wie oft ein bestimmtes Wort in einem Bereich vorkommt

Hinweis: Besuchen Sie unsere Seite über Wörter zählen um mehr über diese Formeln zu erfahren.

2/10 abgeschlossen! Erfahren Sie mehr über Zähl- und Summenfunktionen >
Gehe zum nächsten Kapitel: Logische Funktionen



^