300 Beispiele

Duplikate finden

Find Duplicates

Doppelte Werte | Verdreifachung | Doppelte Zeilen



Dieses Beispiel zeigt Ihnen, wie es geht doppelte Werte finden (oder dreifach) und wie man doppelte Zeilen in . findet Excel .

Doppelte Werte

Führen Sie die folgenden Schritte aus, um doppelte Werte in Excel zu finden und hervorzuheben.





1. Wählen Sie den Bereich A1:C10.

Duplikate in Excel finden



2. Klicken Sie auf der Registerkarte Start in der Gruppe Stile auf Bedingte Formatierung.

Klicken Sie auf Bedingte Formatierung

3. Klicken Sie auf Regeln zum Hervorheben von Zellen, Werte duplizieren.

Klicken Sie auf Regeln für Zellen hervorheben, Werte duplizieren

4. Wählen Sie einen Formatierungsstil aus und klicken Sie auf OK.

Wählen Sie einen Formatierungsstil aus

Ergebnis. Excel hebt die doppelten Namen hervor.

Duplikate

Hinweis: Wählen Sie Eindeutig aus der ersten Dropdown-Liste, um die eindeutigen Namen hervorzuheben.

Verdreifachung

Standardmäßig hebt Excel Duplikate (Juliet, Delta), Triplikate (Sierra) usw. hervor (siehe vorheriges Bild). Führen Sie die folgenden Schritte aus, um nur Dreiergruppen hervorzuheben.

1. Erstens, klar die vorherige bedingte Formatierungsregel.

2. Wählen Sie den Bereich A1:C10.

3. Klicken Sie auf der Registerkarte Start in der Gruppe Stile auf Bedingte Formatierung.

Klicken Sie auf Bedingte Formatierung

4. Klicken Sie auf Neue Regel.

Neue Regel

5. Wählen Sie 'Formel verwenden, um zu bestimmen, welche Zellen formatiert werden sollen'.

6. Geben Sie die Formel ein = ZÄHLENWENN ($A:$C,A1)=3

wie man eine Summenformel in Excel macht

7. Wählen Sie einen Formatierungsstil aus und klicken Sie auf OK.

Neue Formatierungsregel

Ergebnis. Excel hebt die dreifachen Namen hervor.

Verdreifachung

Erklärung: = ZÄHLENWENN ($A:$C,A1) zählt die Anzahl der Namen im Bereich A1:C10, die dem Namen in Zelle A1 entsprechen. Wenn ZÄHLENWENN($A:$C,A1) = 3, formatiert Excel Zelle A1. Schreiben Sie immer die Formel für die obere linke Zelle im ausgewählten Bereich (A1:C10). Excel kopiert die Formel automatisch in die anderen Zellen. Somit enthält Zelle A2 die Formel =ZÄHLENWENN($A:$C,A2)=3, Zelle A3 =ZÄHLENWENN($A:$C,A3)=3 usw. Beachten Sie, wie wir ein absoluter Bezug ($A:$C), um diese Referenz zu beheben.

Hinweis: Sie können jede beliebige Formel verwenden. Verwenden Sie beispielsweise diese Formel =COUNTIF($A:$C,A1)>3, um Namen hervorzuheben, die mehr als dreimal vorkommen.

Doppelte Zeilen

Um doppelte Zeilen in Excel zu finden und hervorzuheben, verwenden Sie ZÄHLENWENN (mit dem Buchstaben S am Ende) anstelle von ZÄHLENWENN.

1. Wählen Sie den Bereich A1:C10.

Finden Sie doppelte Zeilen in Excel

2. Klicken Sie auf der Registerkarte Start in der Gruppe Stile auf Bedingte Formatierung.

Klicken Sie auf Bedingte Formatierung

3. Klicken Sie auf Neue Regel.

Neue Regel

4. Wählen Sie 'Formel verwenden, um zu bestimmen, welche Zellen formatiert werden sollen'.

5. Geben Sie die Formel ein=ZÄHLENWENN(Tiere,$A1,Kontinente,$B1,Länder,$C1)>1

6. Wählen Sie einen Formatierungsstil aus und klicken Sie auf OK.

Doppelte Zeilen hervorheben

Beachten Sie das benannter Bereich Tiere bezieht sich auf den Bereich A1:A10, der benannte Bereich Kontinente bezieht sich auf den Bereich B1:B10 und der benannte Bereich Länder bezieht sich auf den Bereich C1:C10.=ZÄHLENWENN(Tiere,$A1,Kontinente,$B1,Länder,$C1)zählt die Anzahl der Zeilen basierend auf mehreren Kriterien (Leopard, Afrika, Sambia).

Ergebnis. Excel hebt die doppelten Zeilen hervor.

Doppelte Zeilen

Erklärung: wennZÄHLENWENN(Tiere,$A1,Kontinente,$B1,Länder,$C1)> 1, d. h. wenn mehrere Zeilen (Leopard, Afrika, Sambia) vorhanden sind, formatiert Excel die Zelle A1. Schreiben Sie immer die Formel für die obere linke Zelle im ausgewählten Bereich (A1:C10). Excel kopiert die Formel automatisch in die anderen Zellen. Wir haben das behoben Hinweis zu jeder Spalte, indem Sie ein $-Symbol vor den Spaltenbuchstaben setzen ($A1, $B1 und $C1). Als Ergebnis enthalten Zelle A1, B1 und C1 die gleiche Formel, Zelle A2, B2 und C2 enthalten die Formel=ZÄHLENWENN(Tiere,$A2,Kontinente,$B2,Länder,$C2)>1, etc.

7. Schließlich können Sie die Duplikate entfernen Tool in Excel, um doppelte Zeilen schnell zu entfernen. Klicken Sie auf der Registerkarte Daten in der Gruppe Datentools auf Duplikate entfernen.

wie man Zellen in Excel bedingt formatiert

Klicken Sie auf Duplikate entfernen

Im folgenden Beispiel entfernt Excel alle identischen Zeilen (blau) mit Ausnahme der ersten gefundenen identischen Zeile (gelb).

Beispiel zum Entfernen von Duplikaten Ergebnis Duplikate entfernen

Hinweis: Besuchen Sie unsere Seite über Duplikate entfernen um mehr über dieses großartige Excel-Tool zu erfahren.

6/10 abgeschlossen! Weitere Informationen zur bedingten Formatierung >
Gehe zum nächsten Kapitel: Diagramme



^